summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2018-09-28 06:31:25 +0000
committerJonas Suhr Christensen <jsc@umbraculum.org>2018-09-28 06:34:07 +0000
commitf352a4e8a1b31c0074ed350dda05a702daf8dc7b (patch)
treeafe16168bd066700a3e60a45033f07217587cd90
parent5208f387eaf28f4378b938066ff1144feed15782 (diff)
dhcp: fix dhcpd configuration
-rw-r--r--recipes-connectivity/dhcp/dhcp_%.bbappend2
-rw-r--r--recipes-connectivity/dhcp/dhcp_%x.bbappend7
-rw-r--r--recipes-connectivity/dhcp/files/dhcpd.conf10
3 files changed, 2 insertions, 17 deletions
diff --git a/recipes-connectivity/dhcp/dhcp_%.bbappend b/recipes-connectivity/dhcp/dhcp_%.bbappend
index 982a70d..501d2ad 100644
--- a/recipes-connectivity/dhcp/dhcp_%.bbappend
+++ b/recipes-connectivity/dhcp/dhcp_%.bbappend
@@ -5,4 +5,4 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
inherit update-rc.d
INITSCRIPT_PACKAGES = "dhcp-server"
INITSCRIPT_NAME = "dhcp-server"
-INITSCRIPT_PARAMS = "start 50 S . stop 50 0 6 1 ."
+INITSCRIPT_PARAMS = "defaults 50"
diff --git a/recipes-connectivity/dhcp/dhcp_%x.bbappend b/recipes-connectivity/dhcp/dhcp_%x.bbappend
deleted file mode 100644
index 9d0da7e..0000000
--- a/recipes-connectivity/dhcp/dhcp_%x.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-#SRC_URI = "file://dhcpd.conf"
-
-
-inherit update-rc.d
-INITSCRIPT_PACKAGES = "dhcp-server"
-INITSCRIPT_NAME = "dhcp-server"
-INITSCRIPT_PARAMS = "start 50 S . stop 50 0 6 1 ."
diff --git a/recipes-connectivity/dhcp/files/dhcpd.conf b/recipes-connectivity/dhcp/files/dhcpd.conf
index f639296..13b74d9 100644
--- a/recipes-connectivity/dhcp/files/dhcpd.conf
+++ b/recipes-connectivity/dhcp/files/dhcpd.conf
@@ -17,16 +17,8 @@ option domain-name-servers ns1.example.org, ns2.example.org;
default-lease-time 600;
max-lease-time 7200;
-# If this DHCP server is the official DHCP server for the local
-# network, the authoritative directive should be uncommented.
-#authoritative;
-
-# Use this to send dhcp log messages to a different log file (you also
-# have to hack syslog.conf to complete the redirection).
-log-facility local7;
-
# A slightly different configuration for an internal subnet.
-subnet 10.5.5.0 netmask 255.255.255.224 {
+subnet 10.5.5.0 netmask 255.255.255.0 {
range 10.5.5.26 10.5.5.30;
default-lease-time 600;
max-lease-time 7200;