summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2018-09-27 17:23:55 +0000
committerJonas Suhr Christensen <jsc@umbraculum.org>2018-09-27 17:23:55 +0000
commitb566306199c88aeee9f145996773ad350cb6ae99 (patch)
tree0dfd117f385dcf9cfe2e7030e78580805f580154
parent6cf5ce1ccf139684984d50ca76ce54c0b4ff16cf (diff)
add basic files to dgimage
-rw-r--r--recipes-images/dgimage/dgimage.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes-images/dgimage/dgimage.bb b/recipes-images/dgimage/dgimage.bb
index fb00e07..d6d8278 100644
--- a/recipes-images/dgimage/dgimage.bb
+++ b/recipes-images/dgimage/dgimage.bb
@@ -1,15 +1,23 @@
DESCRIPTION = "dginabox image"
+inherit core-image
+
# customize IMAGE_INSTALL as follows
IMAGE_INSTALL = "\
+ busybox \
+ modutils-initscripts \
+ netbase \
+ base-files \
+ base-passwd \
+ openssh \
+ libstdc++ \
drumgizmo \
openssh \
dhcp-server \
spiaudio-module \
"
-inherit core-image
MACHINE_EXTRA_RDEPENDS += " spiaudio-module"
# Add extra space to the rootfs image
-IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 3000000"
+IMAGE_ROOTFS_EXTRA_SPACE_append += "+ 300000"