summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 32f158d..c26b017 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -7,7 +7,7 @@ TESTS = resource enginetest paintertest configfile audiocache \
audiocachefile audiocacheidmanager audiocacheeventhandler \
randomtest atomictest syncedsettingstest imagecachetest \
semaphoretest drumkitcreatortest bytesizeparsertest notifiertest \
- dgxmlparsertest domloadertest
+ dgxmlparsertest domloadertest configparsertest
EXTRA_DIST = \
dgunit.h \
@@ -217,4 +217,16 @@ domloadertest_SOURCES = \
scopedfile.cc \
dgtest.cc
+configparsertest_CXXFLAGS = -DOUTPUT=\"configparsertest\" \
+ -I$(top_srcdir)/src -I$(top_srcdir)/include -I$(top_srcdir)/hugin \
+ -I$(top_srcdir)/pugixml/src $(EXPAT_CFLAGS)
+configparsertest_LDFLAGS = $(EXPAT_LIBS)
+configparsertest_SOURCES = \
+ $(top_srcdir)/hugin/hugin.c \
+ $(top_srcdir)/src/configparser.cc \
+ $(top_srcdir)/src/saxparser.cc \
+ $(top_srcdir)/pugixml/src/pugixml.cpp \
+ configparsertest.cc \
+ dgtest.cc
+
endif