summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Suhr Christensen <jsc@umbraculum.org>2018-09-27 18:11:45 +0000
committerJonas Suhr Christensen <jsc@umbraculum.org>2018-09-27 18:11:45 +0000
commit44a4bd03bbea1cd1a9d50d0cdd1b51d7d165ccf1 (patch)
tree842e8f8d7ea29a96b169639308cfc9e25c0621a6
parentcb627d3febae48b9b76a6b4991c49b2851ea2739 (diff)
dhcpd: fix wrong wildcard match in bbappend file and clenup dhcpd config
-rw-r--r--recipes-connectivity/dhcp/dhcp_%.bbappend8
-rw-r--r--recipes-connectivity/dhcp/files/dhcpd.conf71
2 files changed, 8 insertions, 71 deletions
diff --git a/recipes-connectivity/dhcp/dhcp_%.bbappend b/recipes-connectivity/dhcp/dhcp_%.bbappend
new file mode 100644
index 0000000..982a70d
--- /dev/null
+++ b/recipes-connectivity/dhcp/dhcp_%.bbappend
@@ -0,0 +1,8 @@
+#SRC_URI = "file://dhcpd.conf"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+inherit update-rc.d
+INITSCRIPT_PACKAGES = "dhcp-server"
+INITSCRIPT_NAME = "dhcp-server"
+INITSCRIPT_PARAMS = "start 50 S . stop 50 0 6 1 ."
diff --git a/recipes-connectivity/dhcp/files/dhcpd.conf b/recipes-connectivity/dhcp/files/dhcpd.conf
index 776b1ff..f639296 100644
--- a/recipes-connectivity/dhcp/files/dhcpd.conf
+++ b/recipes-connectivity/dhcp/files/dhcpd.conf
@@ -25,80 +25,9 @@ max-lease-time 7200;
# have to hack syslog.conf to complete the redirection).
log-facility local7;
-# No service will be given on this subnet, but declaring it helps the
-# DHCP server to understand the network topology.
-
-#subnet 10.152.187.0 netmask 255.255.255.0 {
-#}
-
-# This is a very basic subnet declaration.
-
-#subnet 10.254.239.0 netmask 255.255.255.224 {
-# range 10.254.239.10 10.254.239.20;
-# option routers rtr-239-0-1.example.org, rtr-239-0-2.example.org;
-#}
-
-# This declaration allows BOOTP clients to get dynamic addresses,
-# which we don't really recommend.
-
-#subnet 10.254.239.32 netmask 255.255.255.224 {
-# range dynamic-bootp 10.254.239.40 10.254.239.60;
-# option broadcast-address 10.254.239.31;
-# option routers rtr-239-32-1.example.org;
-#}
-
# A slightly different configuration for an internal subnet.
subnet 10.5.5.0 netmask 255.255.255.224 {
range 10.5.5.26 10.5.5.30;
default-lease-time 600;
max-lease-time 7200;
}
-
-# Hosts which require special configuration options can be listed in
-# host statements. If no address is specified, the address will be
-# allocated dynamically (if possible), but the host-specific information
-# will still come from the host declaration.
-
-#host passacaglia {
-# hardware ethernet 0:0:c0:5d:bd:95;
-# filename "vmunix.passacaglia";
-# server-name "toccata.fugue.com";
-#}
-
-# Fixed IP addresses can also be specified for hosts. These addresses
-# should not also be listed as being available for dynamic assignment.
-# Hosts for which fixed IP addresses have been specified can boot using
-# BOOTP or DHCP. Hosts for which no fixed address is specified can only
-# be booted with DHCP, unless there is an address range on the subnet
-# to which a BOOTP client is connected which has the dynamic-bootp flag
-# set.
-#host fantasia {
-# hardware ethernet 08:00:07:26:c0:a5;
-# fixed-address fantasia.fugue.com;
-#}
-
-# You can declare a class of clients and then do address allocation
-# based on that. The example below shows a case where all clients
-# in a certain class get addresses on the 10.17.224/24 subnet, and all
-# other clients get addresses on the 10.0.29/24 subnet.
-
-#class "foo" {
-# match if substring (option vendor-class-identifier, 0, 4) = "SUNW";
-#}
-
-#shared-network 224-29 {
-# subnet 10.17.224.0 netmask 255.255.255.0 {
-# option routers rtr-224.example.org;
-# }
-# subnet 10.0.29.0 netmask 255.255.255.0 {
-# option routers rtr-29.example.org;
-# }
-# pool {
-# allow members of "foo";
-# range 10.17.224.10 10.17.224.250;
-# }
-# pool {
-# deny members of "foo";
-# range 10.0.29.10 10.0.29.230;
-# }
-#}