blob: 14189c9df6b299972f21195fe1d746c2cf1a52fd (
plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
|
#pragma once
#include <memory>
#if defined(X11)
#include <X11/Xlib.h>
#endif
#if defined(WIN32)
#define WIN32_LEAN_AND_MEAN
#include <windows.h>
#endif
#ifdef LV2
#include <pluginlv2.h>
#endif
#ifdef VST
#include <pluginvst.h>
#endif
#include <drumgizmo.h>
#include <audioinputenginemidi.h>
#include <audiooutputengine.h>
#include <plugingui.h>
class DrumGizmoPlugin
#ifdef LV2
: public PluginLV2
#endif
#ifdef VST
: public PluginVST
#endif
{
public:
#ifdef VST
DrumGizmoPlugin(audioMasterCallback audioMaster);
#else
DrumGizmoPlugin();
#endif
void onFreeWheelChange(bool freewheel) override;
void onFramesizeChange(size_t framesize) override;
void onSamplerateChange(float samplerate) override;
void onActiveChange(bool active) override;
std::string onStateSave() override;
void onStateRestore(const std::string& config) override;
size_t getNumberOfMidiInputs() override;
size_t getNumberOfMidiOutputs() override;
size_t getNumberOfAudioInputs() override;
size_t getNumberOfAudioOutputs() override;
std::string getId() override;
void process(size_t pos,
const std::vector<MidiEvent>& input_events,
std::vector<MidiEvent>& output_events,
const std::vector<const float*>& input_samples,
const std::vector<float*>& output_samples,
size_t count) override;
bool hasGUI() override;
void createWindow(void *parent) override;
void onDestroyWindow() override;
void onShowWindow() override;
void onHideWindow() override;
void onIdle() override;
void closeWindow() override;
private:
class Input
: public AudioInputEngineMidi
{
public:
Input(DrumGizmoPlugin& plugin);
bool init(const Instruments& instruments) override;
void setParm(const std::string& parm, const std::string& value) override;
bool start() override;
void stop() override;
void pre() override;
void run(size_t pos, size_t len, std::vector<event_t>& events) override;
void post() override;
bool isFreewheeling() const override;
protected:
DrumGizmoPlugin& plugin;
const Instruments* instruments{nullptr};
};
class Output
: public AudioOutputEngine
{
public:
Output(DrumGizmoPlugin& plugin);
bool init(const Channels& channels) override;
void setParm(const std::string& parm, const std::string& value) override;
bool start() override;
void stop() override;
void pre(size_t nsamples) override;
void run(int ch, sample_t *samples, size_t nsamples) override;
void post(size_t nsamples) override;
sample_t *getBuffer(int ch) const override;
size_t getBufferSize() const override;
bool isFreewheeling() const override;
protected:
DrumGizmoPlugin& plugin;
};
Input input{*this};
const std::vector<MidiEvent>* input_events{nullptr};
Output output{*this};
const std::vector<float*>* output_samples{nullptr};
Settings settings;
std::shared_ptr<GUI::PluginGUI> plugin_gui;
std::shared_ptr<DrumGizmo> drumgizmo;
};
|