summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2015-05-22 10:39:49 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2015-05-22 10:39:49 +0200
commit158838f9b52d21610626f55964170a3e82f6ccdb (patch)
tree0dee778483d667209aca5f2a0a09d9f0c213bca0 /test/Makefile.am
parentbef1d5542f926a3b942374707dd56041013d35ff (diff)
parent2699cb7d324ffb1d2adc62e1f62434397aa39e2d (diff)
Merge with master
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e5760c8..6526f22 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,7 +1,7 @@
# Rules for the test code (use `make check` to execute)
include $(top_srcdir)/src/Makefile.am.drumgizmo
-TESTS = engine gui resampler lv2 cachemanager
+TESTS = engine gui resampler lv2 configfile cachemanager
check_PROGRAMS = $(TESTS)
@@ -54,3 +54,12 @@ lv2_SOURCES = \
test.cc \
lv2_test_host.cc \
lv2.cc
+
+configfile_CXXFLAGS = -DOUTPUT=\"configfile\" $(CPPUNIT_CFLAGS) \
+ -I$(top_srcdir)/hugin
+configfile_LDFLAGS = $(CPPUNIT_LIBS)
+configfile_SOURCES = \
+ $(top_srcdir)/src/configfile.cc \
+ $(top_srcdir)/hugin/hugin.c \
+ test.cc \
+ configtest.cc