summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2018-03-21 20:46:24 +0100
committerBent Bisballe Nyeng <deva@aasimon.org>2018-03-21 20:46:24 +0100
commite21e14223b6d87b29221b29488d1b09895912527 (patch)
tree99237cc38c806f6ca8f5460dfa9a721e0bfece1c /src/Makefile.am
parent81cdd02735b4cd43f5f45419624ba3d062241b57 (diff)
DGEdit is now officially a Qt5 project.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 734152c..b7fb48d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,9 @@
+#export QT_SELECT=qt5
+
bin_PROGRAMS = dgedit
dgedit_LDADD = $(SNDFILE_LIBS) $(QT_LIBS) $(AO_LIBS) \
- $(shell ../tools/MocList o ) qrc_dgedit.o
+ $(shell ../tools/MocList o ) qrc_dgedit.o
dgedit_CXXFLAGS = $(SNDFILE_CXXFLAGS) $(QT_CFLAGS) $(AO_CFLAGS)
AM_CXXFLAGS = $(QT_CFLAGS)
@@ -57,7 +59,7 @@ qrc_%.cc: %.qrc
rcc $< > $@
%.moc.cc: %.h
- $(QT_MOC) -o $@ $<
+ QT_SELECT=qt5 $(QT_MOC) -o $@ $<
#
# ui files not used in this project...
@@ -70,4 +72,3 @@ qrc_%.cc: %.qrc
# command for creating .res file from .rc on Win32
%.res: %.rc
rc $<
-