summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBent Bisballe Nyeng <deva@aasimon.org>2014-09-08 20:48:38 +0200
committerBent Bisballe Nyeng <deva@aasimon.org>2014-09-08 20:48:38 +0200
commit7776aa97fc1c69a8f28ba4bab7387fb96be9a6e4 (patch)
tree8e23cfbfe7e93bdfad4421ccb0ec8c280a0b43ed /src/Makefile.am
parent56f5965ffa2538dfa482ae9460e9579b4a04f8fb (diff)
Import dgedit from drumgizmo repository (split into its own project).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..734152c
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,73 @@
+bin_PROGRAMS = dgedit
+
+dgedit_LDADD = $(SNDFILE_LIBS) $(QT_LIBS) $(AO_LIBS) \
+ $(shell ../tools/MocList o ) qrc_dgedit.o
+
+dgedit_CXXFLAGS = $(SNDFILE_CXXFLAGS) $(QT_CFLAGS) $(AO_CFLAGS)
+AM_CXXFLAGS = $(QT_CFLAGS)
+
+dgedit_SOURCES = \
+ dgedit.cc \
+ audioextractor.cc \
+ canvas.cc \
+ canvastool.cc \
+ canvastoollisten.cc \
+ canvastoolselections.cc \
+ canvastoolthreshold.cc \
+ canvaswidget.cc \
+ filelist.cc \
+ itemeditor.cc \
+ mainwindow.cc \
+ mipmap.cc \
+ player.cc \
+ samplesorter.cc \
+ selection.cc \
+ selectioneditor.cc \
+ volumefader.cc \
+ zoomslider.cc
+
+EXTRA_DIST = \
+ audioextractor.h \
+ canvas.h \
+ canvastool.h \
+ canvastoollisten.h \
+ canvastoolselections.h \
+ canvastoolthreshold.h \
+ canvaswidget.h \
+ filelist.h \
+ itemeditor.h \
+ mainwindow.h \
+ mipmap.h \
+ player.h \
+ samplesorter.h \
+ selection.h \
+ selectioneditor.h \
+ sleep.h \
+ volumefader.h \
+ zoomslider.h \
+ dgedit.qrc
+
+dgedit_MOC = $(shell ../tools/MocList cc )
+
+BUILT_SOURCES = $(dgedit_MOC) qrc_dgedit.cc
+
+CLEANFILES = $(BUILT_SOURCES)
+
+qrc_%.cc: %.qrc
+ rcc $< > $@
+
+%.moc.cc: %.h
+ $(QT_MOC) -o $@ $<
+
+#
+# ui files not used in this project...
+#%.h: %.ui
+# $(QT_UIC) -o $@ $<
+#
+#%.cc: %.ui
+# $(QT_UIC) -o $@ -impl $*.h $<
+
+# command for creating .res file from .rc on Win32
+%.res: %.rc
+ rc $<
+